XML::LibXSLT and <xsl:import> bug - possible bug in XML::LibXML::SAX::Parser?

Toby Corkindale tjc at wintrmute.net
Tue Feb 21 15:01:52 GMT 2006

Note: This bug appears similar to http://rt.cpan.org/Public/Bug/Display.html?id=15723
Hopefully some extra clues we've dug up might help though.

This is odd:
I updated SOAP::Lite on a machine, and then afterwards discovered that an
application using XML::LibXSLT was now failing to process some templates.
It fails on <xsl:import> nodes, and I can reproduce it in a simple stand-alone
test. (A workaround Matt discovered is to use parse_stylesheet_file() rather
than loading the XML via XML::LibXML and parsing the document over to

Curiously, XML::LibXSLT fails one of its own tests now too. (Couldn't create
file parser context @ t/05quick.t line 20)

Unfortunately, I couldn't work out *why* this side-effect occured as a result of
updating SOAP::Lite! Nor, can I work out how to fix it.
I've tried downgrading libxml2, XML::LibXML, libxslt, XML::LibXSLT to their
next-oldest versions, one at a time, and as a group, and I've tried upgrading
them to current versions, if they were not already there, without achieving
any improvements.

After some investigation together with Matt Lawrence, and the only difference
I've spotted between this machine and one that still works, is the list of XML
parsers available to XML::SAX.

The working machine only lists XML::SAX::PurePerl, whereas the failing machine
lists that, as well as XML::LibXML::SAX::Parser.

I'm not sure exactly how this could be causing the import issue though?


Turning and turning in the widening gyre/The falcon cannot hear the falconer;
Things fall apart, the centre cannot hold/Mere anarchy is loosed upon the world
(gpg --keyserver www.co.uk.pgp.net --recv-key B1CCF88E)

More information about the london.pm mailing list