Debian is being hateful

Aaron Crane perl at
Mon Jun 4 20:50:00 BST 2007

David Cantrell writes:
>   WARNING: POSIX threads library NPTL requires kernel version
>   2.6.1 or later. If you use a kernel 2.4, please upgrade it
>   before installing glibc.
>   dpkg: error ...
> Fair enough, time for a kernel upgrade:
>   $ sudo apt-get install kernel-image-2.6-686
>     binutils: Depends: libc6 (>= 2.5-5) but 2.3.6.ds1-13 is to be
>       installed
> OK, I'll try that then:
>   $ sudo apt-get -f install
>   The following extra packages will be installed:
>     libc6
> Stupid piece of shit.  Any clues about how to fix it?

Try installing a 2.6 kernel from stable or oldstable rather than testing?
Once you've got any model of 2.6 kernel, libc6 will presumably install,
which should then allow a subsequent upgrade to the testing 2.6 kernel.

There's a sneakier approach that requires fewer reboots, but is far more
likely to break your system: edit /var/lib/dpkg/info/libc6.preinst, and
comment out the lines that refuse to install on 2.6 kernels.  Then make
sure you install the newer kernel before you try to run any multithreaded
code, lest bad things happen.  You may want to install a static sash or
busybox before risking that.  Note: I have no idea whether any of the
Debian package-installation toolchain is multithreaded.

Aaron Crane

More information about the mailing list