Any IIS 6 Perl CGI gurus out their with their sanity intact

Bob Browning bob at
Wed Nov 14 12:24:17 GMT 2007

Oops - sorry ...

I tried that.  I put print "content-type:text/html\n\nhello"; in the top of
the file and it came out.  Then moved it above the first require, still OK,
then to the top of the first require and nothing.  

Then eventually got to a point where we had a two line program and a one
line require that worked in cgi-bin but not in a subdirectory. Or something
- my brain quite addled now after a day and a half of this madness.  Hardly
a sensible diagnostic procedure.

The issue isn't really this.  It is being taught to fish rather than being
given dinner if you know what I mean.  On Unix we just look in the apache
error log and everything is clear.


-----Original Message-----
From: at
[ at] On Behalf Of Nigel Rantor
Sent: 14 November 2007 11:18
To: Perl M[ou]ngers
Subject: Any IIS 6 Perl CGI gurus out their with their sanity intact

People *will* get annoyed if you hi-jack threads like this. Either that 
or you'll get fewer answers since some people may have set their readers 
to ignore the particular thread you hi-jacked.

Bob Browning wrote:
 > Actually sanity is not a prerequisite, but we are trying to set up
 > our CMS on IIS 6 Windows 2003 Web edition, CGI / Active Perl.
 > We spent the whole of yesterday trying to figure out where the error
 > messages for Perl go.  We have a program that runs from the command
 > line, gives out the mime headers and html as expected.  But as a cgi
 > program is crashes.  It seems to fail on the first require();
 > The problem is not that we probably couldn't sort it out, the problem
 > is that we can't find any sort of error log coming from Perl.   We
 > searched the web for most of yesterday morning and could only find

I can't really help here, you can always try to explicitly redirect 
STDERR somewhere else at the top of the script. If the error is before 
that then I'd consider cutting out require's until you have something 
that works and then add them back one-by-one.

It sounds like it could just be that the web server doesn't have the 
same environment variables set as your shell does and is missing the 
PERL5LIB that your console gives you.


More information about the mailing list