Wide character in syswrite

Matt Lawrence matt.lawrence at virgin.net
Tue Dec 11 16:20:37 GMT 2007

Robert Rothenberg wrote:
> So I'm experimenting with Net::Dict and have a problem when I submit certain
> words with wide characters (e.g. Polish L-slash):
>  Wide character in syswrite at /usr/local/share/perl/5.8.8/Net/Cmd.pm line
> 232, <STDIN> line 2.
> Does anyone know of a workaround for this?
I don't know specifically about this module, but it looks like it
doesn't handle unicode at all, if the underlying dict service expects
unicode, then it's a bug in the module. Otherwise, you can decode the
input into the correct 8-bit character set with Encode, but this assumes
that you know the character set to use.

I just tried typing canapé into http://www.dict.org/ and it wouldn't
have it. "canape" worked fine though. I also note that the page was
served as UTF-8, and the form was submitted as UTF-8 too.

Sorry I couldn't be of more help


More information about the london.pm mailing list