Alternatives to version numbering

Abigail abigail at
Thu Jan 3 15:54:51 GMT 2008

On Tue, Dec 11, 2007 at 02:22:25PM +1100, Toby Corkindale wrote:
> What if you have a module that you want to use, and it says it requires Perl
> 5.8.8 - but you have Perl 5.8.1 with vendor patches on your system - maybe it
> includes the fixes or functionality the module author wants? 
> Wouldn't it be nice if their requirements had been expressed in a way that
> dealt with that?


If I get a module from CPAN, and it says it needs 5.8.8, and I have 5.8.1,
I'm pretty certain it ain't going to work. Doesn't take much effort,
easy to check. OTOH, the module may list its 1320 pieces of Perl it
uses. Do you really think I would bother checking each and every piece
of functionality?  Of course, the module author could say "5.8.2 and this
dozen pieces of functionality", but that's just the worst of both worlds.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the mailing list