Dirk Koopman djk at tobit.co.uk
Mon Jan 7 12:54:56 GMT 2008

Has anybody tried perl 5.10 out on some real code? I appear to be 
getting the odd problemette...

For instance, try this:-

package fred;

our @ISA = qw(fred);


Although it is a manifestly silly error, I don't think that it merits a 
(new) fatal error like this:-

"Recursive inheritance detected in package 'fred' at fred.pm line 3."

What worries me more is the implication that something fundamental has 
changed in the way that inheritance works.

I had some code written many years ago which happened to have the 
package name left in @ISA (done before I had *any* understanding) 
together with its real parent class name. This has worked quite happily 
since 5.00503 -> 5.8.8. So it was a bit of a surprise to get a fatal 
error in 5.10.

And whilst I am about it, IO::Socket::INET6 and its dependencies do not 
install without force in 5.10 and, worse, chucks out 3 or 4 redefinition 
warnings everytime one launches a script using it.

More information about the london.pm mailing list