Correct way to specify minimum Perl version required.
david at cantrell.org.uk
Fri Aug 8 09:58:25 BST 2008
On Fri, Aug 08, 2008 at 09:42:56AM +0100, Andy Wardley wrote:
> If I have a distribution that requires, say, Perl 5.6.0, then will it
> to put "use 5.6.0" at the top of my Makefile.PL, or do I need something else
> (in the style of the PREREQ_PM) to tell CPAN testers to stop testing my
> modules on older versions of Perl.
Don't use three-part version numbers, say 'use 5.006'. Or if you need,
eg, 5.6.2, 'use 5.006002'.
David Cantrell | http://www.cantrell.org.uk/david
EIN KIRCHE! EIN KREDO! EIN PAPST!
More information about the london.pm