Xcode 4.0.2 and XS modules

Sue Spence sue at pennine.com
Wed Apr 27 10:04:03 BST 2011

On 26 April 2011 13:24, Simon Cozens <simon at simon-cozens.org> wrote:
> On 23/04/2011 13:46, Sue Spence wrote:
>>> Beyond installing my own Perl
>> Do this.  Best to ignore the system Perl IMO.
> I don't get it. I've never used anything other than system Perl all the time
> I've been using OS X, and I don't recall any problems. (Of course, that may be
> the RDF talking.) In fact, I get annoyed with things like macports/fink/etc
> that won't accept system Perl (or system X11) and try and do their own thing,
> and have since switched to homebrew, which seems to get a lot right.

I may have slightly overstated the case.  If what you have is working
for you, great. It clearly wasn't doing the job for Simon.  I have a
tendency to want

a) specific version(s) of Perl, usually due to CPAN dependencies, but not always
b) better certainty that it will not be disturbed by Apple

I install and manage my own versions of other software too, for much
the same reasons.

More information about the london.pm mailing list