does CPAN still work?

Michael Stillwell mjs at
Fri Aug 10 12:26:16 BST 2007

On 8/5/07, Andy Armstrong <andy at> wrote:
> On 5 Aug 2007, at 22:20, Michael Stillwell wrote:
> > Does installing modules via CPAN still work for anyone else?  Over
> > the past few years more and more modules have been failing tests;
> > just about everything needs to be installed via "force" now.  (e.g.
> > an install of Bundle::CPAN.)
> Apart from Bundle::CPAN (which worked fine for me recently) let me
> know something else that's failed for you recently and I'll try it here.

The day after posting my frustrated whine I tried installing a few
things on OS X that have caused a lot of grief in the past
(XML::LibXML, XML::LibXSLT, DBD::SQLite) and they seemed to be okay.
But today, on SunOS, I'm having a problem with CPAN itself!

I downloaded from 1.9102 from (because installing from CPAN
itself wasn't working right, I think because it was using parts of the
system's CPAN, plus a local $HOME/.cpan/build/,
configured, make'd, make test'd (all okay) and installed, and now just
running it dies!:

  $ cpan
  Can't use an undefined value as a symbol reference at
/data/homes/mstillwel/local/lib/CPAN/ line 1015.

It seems like no-one else is having these problems, but I didn't think
I had an especially unusual setup

All I really want to do is get CPAN to install modules with the equivalent of:

perl Makefile.PL LIB=$HOME/local/lib/CPAN

(I find the command-line a lot more reliable--but it doesn't follow
dependencies, which makes it not so useful.)


+44 78 2118 9049

More information about the mailing list