5 minimums for any perl script?

David Cantrell david at cantrell.org.uk
Mon Jan 30 12:55:31 GMT 2012

On Mon, Jan 30, 2012 at 11:07:53AM +1100, Damian Conway wrote:

> This advice is mainly because there are still an absurd number of people
> stuck on 5.8 (for perfectly good reasons), which version I now no longer
> support. A simple 'use 5.010' in the code avoids an endless amount of
> fruitless email discussion and cajoling about my decision to treat 5.10
> (and soon, 5.12) as my minimal supported platform.

I used to bitch and moan about authors who did this.  Then I STFU and
wrote some code.  I'm surprised how few people use cpXXXan, it was
written for those people who can't easily upgrade their perl.

David Cantrell | A machine for turning tea into grumpiness

One person can change the world, but most of the time they shouldn't
    -- Marge Simpson

More information about the london.pm mailing list